«

»

Feb 12 2016

JD Edwards Standalone E920 Troubleshooting guide

VN:F [1.9.22_1171]
Rating: 5.0/5 (3 votes cast)

This article is made to help everyone to install JD Edwards Standalone successfully. We have noticed a few obstacles while installing Standalone E920

We are sharing our experience to help everyone. Hope this information will help you guys! Below are the issues that can be occur while installing JD Edwards Standalone E920.

  1. Cannot connect to the database
  2. Weblogic Server not detected
  3. Business function Library load Failed
  4. Unable to Locate Security server
  5. JDB9900160 – Failed to load driver library libora121.so
  6. Local web configuration stucks @ 94%
  7. Unable to execute UBE on standalone

1. Cannot connect to the database

Error Message :

PackageCause : OUI Installer is not able to connect to the E1local 12c DB

Solution : This could be because of multiple reasons. However you can resolve the issue by following below steps

1. Go to Services and check for services OracleServiceE1local and OracleE1LocalTNSListener

2. Navigate to the below location ( C:\Oracle\E1Local\NETWORK\ADMIN)
 
Make sure to select listener.ora & tnsnames.ora have the value for Host as actual Hostname (Instead of IP or Localhost)  in both the files

3. Stop and restart the OracleE1LocalTNSListener and try to resinstall Standalone client or click ok on the error message

2. Weblogic Server is not detected

Error Message :

WLS3Cause : Weblogic Server 12.1.3 was not installed using 32 bit JDK

Solution : Standalone E920 local web can be installed only on weblogic server 12.1.3 .So install 32 bit JDK and install Weblogic server. Once WLS installed, Navigate the below location of Standalone Setup file

X:\Standalone\ThirdParty\webdevfeature\WLSH4A\install

Execute the setup.exe as Run as administrator and configure the local web.

Make sure the select the home as JDE_E920_Client1 and Enter the weblogic password (i.e weblogic1)
 
3. Business function Library load Failed

Error Message :

rtl

rtl1 Cause : Necessary RTLs for Standalone 9.2 was not installed
 
Solution : Microsoft Visual Studio 2013 Redistributable (x86) is required for E920 Standalone. Please download and install “vcredist_x86.exe”

http://www.microsoft.com/en-us/download/details.aspx?id=40784

4. Unable to Locate Security server

Error Message :

WLS6Cause : This could be because of multiple reasons. However you can resolve this issue by following below steps

JDE Standalone Client is not able to get Security Pass from Enterprise server because of E1local DB issue

Solution : Check the jde.log & Log file under below location for more information

C:\Oracle\diag\rdbms\e1local\e1local\alert\log.xml –> Verify the log , E1local DB is started without any error message

If Access denied error message appears in the Log file, make sure to provide the required permission to the below Folder to E1local DB user

1. C:\Oracle –> E1local DB should own the file and user should have Full control access

2. C:\E920_1\DEMO\data and C:\E920_1\DEMo\Spec should own the file and user should have Full control access

Make sure all the .DMP & .DBF files have full control access

3. Now start the OracleServiceE1local and check the log.xml. If its started succesfully, try to login into JDE Standalone client.

5. JDB9900160 – Failed to load driver library libora121.so

Error Message :  JDB9900160 – Failed to load driver library libora121.so

Cause : ORACLE 32bit client was installed without “Administrator” type. Because of this, the 32-bit version sqlplus.exe was not installed. When launching active console, sqlplus.exe is retrieved from bin folder of E1Local instance. This is 64-bit version and it will not work with 32-bit jdbocixxx.dll dynamic library

Solution : Oracle 32 bit client needs to be reinstalled and select “Administrator” for type of installation on Stanalone E920.

6. Local Web configuration stuck @ 95 %
 
Error message :

WLS IssueCause :  Anti virus software and windows firewall was on
 
Solution : Switch off the anti virus and windows firewall and try to reinstall and also make sure Node manager port number and Weblogic port is not used by any other process.

7. Unable to execute UBE on standalone

Error Message : After you run the UBE from BV, nothing happens

Solution :

  • Go to windows command prompt and type HOSTNAME to determine your local PC local host name.
  • Start E1 Solution Explorer.
  • Go to P986115 – Row exit until the maintenance form for “Data Source Revisions”
    Change “Logical Server Name” to the local HOSTNAME.
    Change “Server Map Data Source Name” to “System Local”
    Click OK to update.
  • Reboot. Start E1 Solution Explorer.
  • Go to P98616 and define the DEFAULT printer with the default paper size.
    Setup DEFAULT printer via P98616 for the local HOSTNAME.
    Setup for for HOSTNAME, (local). This will allow you to submit UBE from web-client.
    *PUBLIC *ALL *ALL *ALL \\corprts1\devprn1 MYCOMPUTER14 AV
  • In JDE.ini change [SECURITY] section to
    SecurityServer=local HOSTNAME
  • Reboot and try executing batch jobs

In the Standalone, your reports outputs are available only in the Printqueue folder, and not in Carousel.

 

Best Regards
JDEE1Tips

JDEE1TipsTraining is Our Passion

Published under the license.

VN:F [1.9.22_1171]
Rating: 5.0/5 (3 votes cast)
JD Edwards Standalone E920 Troubleshooting guide, 5.0 out of 5 based on 3 ratings
(Visited 3,433 times, 1 visits today)

About the author

JDEE1Tips

We always like to share our Knowledge to everyone. We are here for sharing and helping you all.
Our goal at JDEE1Tips is to provide effective Training and consulting to boost your business, be it a small or a large organization.
Our JD Edwards consultants have experience in a multitude of installation and upgrade projects. Our research team keeps us abreast of the latest JD Edwards technology changes and additions. If you need help with your IoT project we have the consultants to make it happen.
We are best in JD Edwards EnterpriseOne Product.

12 comments

1 ping

Skip to comment form

  1. Nishant Sharma

    I created an E920 Virtual Machine the configuration is as follows:

    OS : Windows 7 Professional (64 bit)

    JDE : E920 standalone

    MSVS : MS VS 2013, Microsoft Visual Studio 2013 Redistributable (x86) and 64 bit

    JDeveloper: 12.1.3

    Web logic 12c

    Database: Oracle 12c

    I can login successfully to JDE. However I’m facing following issues:

    1. I cannot launch MS VS for BSFN development and getting, ” Unable to start MS visual C++ 7.1……..” I checked JDE.ini and found all entries seems OK.

    2. I cannot launch JDeveloper, even I cannot set JDeveloper Path in JDE.

    Can someone help me with these issues?

    Thanks,

    Nishant Sharma

    VN:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    1. JDEE1Tips

      Issue is because of JDE.ini , Send us the JDE.ini we will help you !

      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      1. Vincenzo

        Hi,

        I have the same issue with visual C++7.1, getting the same error message.
        My configuration:

        OS : Windows 10 Professional (64 bit)
        JDE : E920 standalone
        MSVS : VS Express 2013

        Can someone help me too?

        Thanks in advance,

        Vincenzo Caserta

        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        1. JDEE1Tips

          Hey Vincenzo,

          You should use visual stuido 2010/2013 Professional or Enterprise Edition and make sure that you have below setting in your jde.ini

          VisualStudioVersion=2013 for VS 2013
          VisualStudioVersion=10 for VS 2010

          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
          1. Vincenzo

            Thank you

            VN:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
  2. Vincenzo

    Hi again,
    I have another issue whit the debbugger.

    When i run the debugger on my E920 Standalone, I recive the messagge “Unable to establish connection with Broker”. It looks like every DEMO had this issue, but I was not able to fix it.

    Can someone support me, please?

    Thanks in advance

    P.S.
    My config:
    OS : Windows 10 Professional (64 bit)
    JDE : E920 standalone
    MSVS : MS VS 2013, Microsoft Visual Studio 2013 Professional (x86) and 64 bit

    VN:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    1. JDEE1Tips

      We have not tried to debug in Standalone 9.2. Let us know which objects you are trying we will try to debug and update you !

      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      1. Vincenzo

        Debugger doesn’t work , anyway I was trying to debug P4210’s ER.
        Thank you

        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
      2. Vincenzo

        Hi,
        do you have any “christmars gift-news” for me? 🙂

        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        1. JDEE1Tips

          Hey Vincenz,

          Wish you happy Christmas 🙂

          Here we have a gift for you ! We tried using debugger on Standalone 9.2 and 9.1, Its working fine.

          We are sending the private mail to you. When you are free reply back , we will look into your system to help your further.

          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
  3. mariordz

    hello guys,,
    this is the second time that this error happend to me..
    1.- I installed E1 with no error
    2. then then I installed BI publiser…
    3.-after installing BI when I login again to web client, I have lost the enterprise menus..

    Do you have any iidea about how to solve this issue ?
    Thanks
    Mario

    VN:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    1. mariordz

      SOLVED.. I guess was an issue with IE, I updated from 8 to 11 and web client works again…

      VN:F [1.9.22_1171]
      Rating: +1 (from 1 vote)
  1. JD Edwards 9.2 Standalone (DEMO) Installation Tutorial by Jde | JDE Source

    […] Before we get started, if you find any issue, do read through the comments or visit the troubleshooting guide for 9.2 installation […]

Leave a Reply